Degraded Performance
Incident Report for Simplecast
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 13:34 EST
Investigating
We are currently experiencing higher than normal load times on our API, which is negatively affecting our API, Dashboard and Simplecast Hosted Sites. RSS feeds, audio streaming and analytics tracking is NOT affected.
Posted Nov 02, 2020 - 12:23 EST
This incident affected: Simplecast.com, Dashboards & Customer Admin, Simplecast Hosted Sites, and Simplecast API.