Stripe Billing System Outage
Incident Report for Simplecast
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 10, 2019 - 19:04 EDT
Monitoring
Our billing provider, Stripe is experiencing downtime which is affecting changes to your billing plan. During this, you might see an error that says "There was a problem with Stripe" in your Simplecast Dashboard. More info on their outage here: https://status.stripe.com
Posted 3 months ago. Jul 10, 2019 - 17:40 EDT
This incident affected: Billing & Secure CC Storage (Stripe).