Connectivity Issues
Incident Report for Simplecast
Resolved
All services are once again running as expected. Admin loading issues were sporadic, and it's our hopes you never even noticed. If any inconvenience arose, we apologize.
Posted over 2 years ago. Apr 05, 2017 - 12:18 EDT
Investigating
We're experiencing connectivity issues and are currently looking into the cause.
Posted over 2 years ago. Apr 05, 2017 - 11:54 EDT