Analytics Reporting Delays
Incident Report for Simplecast
Resolved
This incident has been resolved.
Posted Oct 30, 2021 - 19:07 EDT
Identified
Your analytics dashboard will show data current as of 15:00UTC, October 30, 2021. Analytics data collected after that time is not currently being represented and NOT lost. We expect the data to be restored shortly and in your Dashboard.
Posted Oct 30, 2021 - 17:00 EDT
This incident affected: Analytics (Retrieval).